re = /([A-Z][^,]+),\s([A-Z]{2})/
str = 'Fort Worth, TX
This is Forth Worth, TX
We are looking for someone from Columbus, MS.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end