const regex = /^GET \S{0,100}\/\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\d){2} HTTP/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GET \\S{0,100}\\\/\\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\\d){2} HTTP', '')
const str = `GET /?lpypmp=eirieisifjtjgkulimwndgqgdgqh&yblb=6&dgqgdgqh=7 HTTP/1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}