$re = '/^GET \S{0,100}\/\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\d){2} HTTP/';
$str = 'GET /?lpypmp=eirieisifjtjgkulimwndgqgdgqh&yblb=6&dgqgdgqh=7 HTTP/1.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);