// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^GET \S{0,100}\/\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\d){2} HTTP").unwrap();
let string = "GET /?lpypmp=eirieisifjtjgkulimwndgqgdgqh&yblb=6&dgqgdgqh=7 HTTP/1.1";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}