#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.\/(?!_exclude\/).*\.vue$"
Local $sString = "./_exclude/file.vue" & @CRLF & _
"./_exclude/file2.vue" & @CRLF & _
"./_exclude/svg/globe.vue" & @CRLF & _
"./some-file.vue" & @CRLF & _
"./svg/cart.vue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")