re = /^\.\/(?!_exclude\/).*\.vue$/m
str = './_exclude/file.vue
./_exclude/file2.vue
./_exclude/svg/globe.vue
./some-file.vue
./svg/cart.vue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end