$re = '/^\.\/(?!_exclude\/).*\.vue$/m';
$str = './_exclude/file.vue
./_exclude/file2.vue
./_exclude/svg/globe.vue
./some-file.vue
./svg/cart.vue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);