using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\.\/(?!_exclude\/).*\.vue$";
string input = @"./_exclude/file.vue
./_exclude/file2.vue
./_exclude/svg/globe.vue
./some-file.vue
./svg/cart.vue";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}