import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.\\/(?!_exclude\\/).*\\.vue$";
final String string = "./_exclude/file.vue\n"
+ "./_exclude/file2.vue\n"
+ "./_exclude/svg/globe.vue\n"
+ "./some-file.vue\n"
+ "./svg/cart.vue";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}