#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(test)(?:=[0-9]{0,})?$"
Local $sString = "Test" & @CRLF & _
"Test=" & @CRLF & _
"Test=45" & @CRLF & _
"Test45" & @CRLF & _
"" & @CRLF & _
"Match text: (?i)^test(?:=[0-9]{0,})?$" & @CRLF & _
"Match has number: .*?=[0-9]{1,}$" & @CRLF & _
"Extract number: .*=([0-9]{1,})$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")