$re = '/(?i)^(test)(?:=[0-9]{0,})?$/m';
$str = 'Test
Test=
Test=45
Test45
Match text: (?i)^test(?:=[0-9]{0,})?$
Match has number: .*?=[0-9]{1,}$
Extract number: .*=([0-9]{1,})$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);