import re
regex = re.compile(r"(?i)^(test)(?:=[0-9]{0,})?$", flags=re.MULTILINE)
test_str = ("Test\n"
"Test=\n"
"Test=45\n"
"Test45\n\n"
"Match text: (?i)^test(?:=[0-9]{0,})?$\n"
"Match has number: .*?=[0-9]{1,}$\n"
"Extract number: .*=([0-9]{1,})$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")