package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^(test)(?:=[0-9]{0,})?$`)
var str = `Test
Test=
Test=45
Test45
Match text: (?i)^test(?:=[0-9]{0,})?$
Match has number: .*?=[0-9]{1,}$
Extract number: .*=([0-9]{1,})$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}