using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(test)(?:=[0-9]{0,})?$";
string input = @"Test
Test=
Test=45
Test45
Match text: (?i)^test(?:=[0-9]{0,})?$
Match has number: .*?=[0-9]{1,}$
Extract number: .*=([0-9]{1,})$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}