import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(test)(?:=[0-9]{0,})?$";
final String string = "Test\n"
+ "Test=\n"
+ "Test=45\n"
+ "Test45\n\n"
+ "Match text: (?i)^test(?:=[0-9]{0,})?$\n"
+ "Match has number: .*?=[0-9]{1,}$\n"
+ "Extract number: .*=([0-9]{1,})$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}