#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\s*\[?(TEST COOKIE|100% to v\d)\]?:?\s*"
Local $sString = "FIVE-244 [Sign Up] Optional Form Fields" & @CRLF & _
"100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy" & @CRLF & _
"[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe" & @CRLF & _
"[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product" & @CRLF & _
"[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch" & @CRLF & _
"[TEST COOKIE] FIVE-240: Demo page A/A test" & @CRLF & _
"[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video" & @CRLF & _
"TEST-321b: Something" & @CRLF & _
"[TEST-123]: This one is weird"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")