$re = '/^\s*\[?(TEST COOKIE|100% to v\d)\]?:?\s*/im';
$str = 'FIVE-244 [Sign Up] Optional Form Fields
100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy
[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe
[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product
[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch
[TEST COOKIE] FIVE-240: Demo page A/A test
[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video
TEST-321b: Something
[TEST-123]: This one is weird';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);