import Foundation
let pattern = #"^\s*\[?(TEST COOKIE|100% to v\d)\]?:?\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
FIVE-244 [Sign Up] Optional Form Fields
100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy
[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe
[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product
[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch
[TEST COOKIE] FIVE-240: Demo page A/A test
[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video
TEST-321b: Something
[TEST-123]: This one is weird
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)