use strict;
my $str = 'FIVE-244 [Sign Up] Optional Form Fields
100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy
[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe
[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product
[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch
[TEST COOKIE] FIVE-240: Demo page A/A test
[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video
TEST-321b: Something
[TEST-123]: This one is weird';
my $regex = qr/^\s*\[?(TEST COOKIE|100% to v\d)\]?:?\s*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}