import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\[?(TEST COOKIE|100% to v\\d)\\]?:?\\s*";
final String string = "FIVE-244 [Sign Up] Optional Form Fields\n"
+ "100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy\n"
+ "[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe\n"
+ "[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product\n"
+ "[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch\n"
+ "[TEST COOKIE] FIVE-240: Demo page A/A test\n"
+ "[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video\n"
+ "TEST-321b: Something\n"
+ "[TEST-123]: This one is weird";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}