# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\[?(TEST COOKIE|100% to v\d)\]?:?\s*"
test_str = ("FIVE-244 [Sign Up] Optional Form Fields\n"
"100% to v1: FIVE-260: [Connectors - Sub pages] CTA copy\n"
"[100% to v2] [FIVE-242] Signup | Footer Social Proof Stripe\n"
"[100% to v1] FIVE-253: [Sitewide] [Nav] Connector Under Product\n"
"[100% to v1] FIVE-212 [Pricing][Desktop] Packaging Plans - June Relaunch\n"
"[TEST COOKIE] FIVE-240: Demo page A/A test\n"
"[TEST COOKIE] FIVE-200 | [Platforms | For Your App][Desktop] Add Testimonial Video\n"
"TEST-321b: Something\n"
"[TEST-123]: This one is weird")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.