#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$"
Local $sString = "FL_0DS906555B_3661_27012221225012_V001_S" & @CRLF & _
"FL_0DS906555C_3661_27012221235012_V001_S" & @CRLF & _
"FL_0DS906555C_3661_27012221225002_V001_S" & @CRLF & _
"FL_0DS906555C_3661_27012221225013_V001_S" & @CRLF & _
"FL_0DS906555C_3661_27012221225012_V001_S"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")