const regex = /^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$', 'gm')
const str = `FL_0DS906555B_3661_27012221225012_V001_S
FL_0DS906555C_3661_27012221235012_V001_S
FL_0DS906555C_3661_27012221225002_V001_S
FL_0DS906555C_3661_27012221225013_V001_S
FL_0DS906555C_3661_27012221225012_V001_S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}