import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$";
final String string = "FL_0DS906555B_3661_27012221225012_V001_S\n"
+ "FL_0DS906555C_3661_27012221235012_V001_S\n"
+ "FL_0DS906555C_3661_27012221225002_V001_S\n"
+ "FL_0DS906555C_3661_27012221225013_V001_S\n"
+ "FL_0DS906555C_3661_27012221225012_V001_S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}