$re = '/^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$/m';
$str = 'FL_0DS906555B_3661_27012221225012_V001_S
FL_0DS906555C_3661_27012221235012_V001_S
FL_0DS906555C_3661_27012221225002_V001_S
FL_0DS906555C_3661_27012221225013_V001_S
FL_0DS906555C_3661_27012221225012_V001_S';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);