import Foundation
let pattern = #"^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FL_0DS906555B_3661_27012221225012_V001_S
FL_0DS906555C_3661_27012221235012_V001_S
FL_0DS906555C_3661_27012221225002_V001_S
FL_0DS906555C_3661_27012221225013_V001_S
FL_0DS906555C_3661_27012221225012_V001_S
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)