using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*0DS906555B)(?=.*_2701222122(?:500[3-9]|501[012])_).*$";
string input = @"FL_0DS906555B_3661_27012221225012_V001_S
FL_0DS906555C_3661_27012221235012_V001_S
FL_0DS906555C_3661_27012221225002_V001_S
FL_0DS906555C_3661_27012221225013_V001_S
FL_0DS906555C_3661_27012221225012_V001_S";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}