#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\$\w+"
Local $sString = "Test()" & @CRLF & _
"" & @CRLF & _
"Func Test()" & @CRLF & _
"" & @CRLF & _
" Local $str = "This is a string with $dollar sign!"" & @CRLF & _
"" & @CRLF & _
"ConsoleWrite("Before: " & $str & @CRLF & _" & @CRLF & _
" "After : " & StringRegExpReplace($str, "\$(\w+)", "no more $1") & @CRLF)" & @CRLF & _
"" & @CRLF & _
"EndFunc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")