using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\$\w+";
string input = @"Test()
Func Test()
Local $str = ""This is a string with $dollar sign!""
ConsoleWrite(""Before: "" & $str & @CRLF & _
""After : "" & StringRegExpReplace($str, ""\$(\w+)"", ""no more $1"") & @CRLF)
EndFunc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}