re = /(?i)\$\w+/
str = 'Test()
Func Test()
Local $str = "This is a string with $dollar sign!"
ConsoleWrite("Before: " & $str & @CRLF & _
"After : " & StringRegExpReplace($str, "\\$(\\w+)", "no more $1") & @CRLF)
EndFunc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end