package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\$\w+`)
var str = `Test()
Func Test()
Local $str = "This is a string with $dollar sign!"
ConsoleWrite("Before: " & $str & @CRLF & _
"After : " & StringRegExpReplace($str, "\$(\w+)", "no more $1") & @CRLF)
EndFunc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}