import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\$\\w+";
final String string = "Test()\n\n"
+ "Func Test()\n\n"
+ " Local $str = \"This is a string with $dollar sign!\"\n\n"
+ "ConsoleWrite(\"Before: \" & $str & @CRLF & _\n"
+ " \"After : \" & StringRegExpReplace($str, \"\\$(\\w+)\", \"no more $1\") & @CRLF)\n\n"
+ "EndFunc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}