$re = '/(?i)\$\w+/';
$str = 'Test()
Func Test()
Local $str = "This is a string with $dollar sign!"
ConsoleWrite("Before: " & $str & @CRLF & _
"After : " & StringRegExpReplace($str, "\\$(\\w+)", "no more $1") & @CRLF)
EndFunc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);