using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d*\.*\d+(?:[+*\/-][+-]?\d*\.*\d+)*$";
string input = @"-0.548*-7+54
*354*/56-+45
.9+-5
4
-6
4/-5*3434.54354-.0254
0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}