import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?\\d*\\.*\\d+(?:[+*\\/-][+-]?\\d*\\.*\\d+)*$";
final String string = "-0.548*-7+54\n"
+ "*354*/56-+45\n"
+ ".9+-5\n"
+ "4\n"
+ "-6\n"
+ "4/-5*3434.54354-.0254\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}