const regex = /^[+-]?\d*\.*\d+(?:[+*\/-][+-]?\d*\.*\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?\\d*\\.*\\d+(?:[+*\\\/-][+-]?\\d*\\.*\\d+)*$', 'gm')
const str = `-0.548*-7+54
*354*/56-+45
.9+-5
4
-6
4/-5*3434.54354-.0254
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}