// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?\d*\.*\d+(?:[+*\/-][+-]?\d*\.*\d+)*$").unwrap();
let string = "-0.548*-7+54
*354*/56-+45
.9+-5
4
-6
4/-5*3434.54354-.0254
0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}