package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d*\.*\d+(?:[+*\/-][+-]?\d*\.*\d+)*$`)
var str = `-0.548*-7+54
*354*/56-+45
.9+-5
4
-6
4/-5*3434.54354-.0254
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}