# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/box(?!-shadow)//gm;t' <<< "//selects box only if what comes after is not -shadow
box-sizing
box-shadow
box-shadows
"