const regex = /box(?!-shadow)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('box(?!-shadow)', 'gm')
const str = `//selects box only if what comes after is not -shadow
box-sizing
box-shadow
box-shadows
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);