re = /box(?!-shadow)/m
str = '//selects box only if what comes after is not -shadow
box-sizing
box-shadow
box-shadows
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result