using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"box(?!-shadow)";
string substitution = @"";
string input = @"//selects box only if what comes after is not -shadow
box-sizing
box-shadow
box-shadows
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}