#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)box(?!-shadow)"
Local $sString = "//selects box only if what comes after is not -shadow" & @CRLF & _
"box-sizing" & @CRLF & _
"box-shadow" & @CRLF & _
"box-shadows" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)