#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[:|@](?=.+)(?!latest)).*$"
Local $sString = "### Should PASS ###" & @CRLF & _
"" & @CRLF & _
"fluentd:v2.5.2" & @CRLF & _
"k8s.gcr.io/ubuntu-slim:0.1" & @CRLF & _
"quay.io/fluentd_elasticsearch/fluentd:v2.5.2" & @CRLF & _
"ubuntu-slim:0.1" & @CRLF & _
"" & @CRLF & _
"### Should FAIL ###" & @CRLF & _
"" & @CRLF & _
"fluentd" & @CRLF & _
"k8s.gcr.io/ubuntu-slim" & @CRLF & _
"quay.io/fluentd_elasticsearch/fluentd:latest" & @CRLF & _
"ubuntu-slim:latest"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")