use strict;
my $str = '### Should PASS ###
fluentd:v2.5.2
k8s.gcr.io/ubuntu-slim:0.1
quay.io/fluentd_elasticsearch/fluentd:v2.5.2
ubuntu-slim:0.1
### Should FAIL ###
fluentd
k8s.gcr.io/ubuntu-slim
quay.io/fluentd_elasticsearch/fluentd:latest
ubuntu-slim:latest';
my $regex = qr/^(?=.*[:|@](?=.+)(?!latest)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}