using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[:|@](?=.+)(?!latest)).*$";
string input = @"### Should PASS ###
fluentd:v2.5.2
k8s.gcr.io/ubuntu-slim:0.1
quay.io/fluentd_elasticsearch/fluentd:v2.5.2
ubuntu-slim:0.1
### Should FAIL ###
fluentd
k8s.gcr.io/ubuntu-slim
quay.io/fluentd_elasticsearch/fluentd:latest
ubuntu-slim:latest";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}