import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[:|@](?=.+)(?!latest)).*$";
final String string = "### Should PASS ###\n\n"
+ "fluentd:v2.5.2\n"
+ "k8s.gcr.io/ubuntu-slim:0.1\n"
+ "quay.io/fluentd_elasticsearch/fluentd:v2.5.2\n"
+ "ubuntu-slim:0.1\n\n"
+ "### Should FAIL ###\n\n"
+ "fluentd\n"
+ "k8s.gcr.io/ubuntu-slim\n"
+ "quay.io/fluentd_elasticsearch/fluentd:latest\n"
+ "ubuntu-slim:latest";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}