re = /^(?=.*[:|@](?=.+)(?!latest)).*$/m
str = '### Should PASS ###
fluentd:v2.5.2
k8s.gcr.io/ubuntu-slim:0.1
quay.io/fluentd_elasticsearch/fluentd:v2.5.2
ubuntu-slim:0.1
### Should FAIL ###
fluentd
k8s.gcr.io/ubuntu-slim
quay.io/fluentd_elasticsearch/fluentd:latest
ubuntu-slim:latest'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end