const regex = /^(?=.*[:|@](?=.+)(?!latest)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[:|@](?=.+)(?!latest)).*$', 'gm')
const str = `### Should PASS ###
fluentd:v2.5.2
k8s.gcr.io/ubuntu-slim:0.1
quay.io/fluentd_elasticsearch/fluentd:v2.5.2
ubuntu-slim:0.1
### Should FAIL ###
fluentd
k8s.gcr.io/ubuntu-slim
quay.io/fluentd_elasticsearch/fluentd:latest
ubuntu-slim:latest`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}