#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((<PackageReference Include=".*" Version=).*)$\s+?^(?=.*^\2.*$)"
Local $sString = "<PackageReference Include="CommandLineParser" Version="2.2.1" />" & @CRLF & _
"" & @CRLF & _
" <PackageReference Include="CommandLineParser" Version="2.2.1" />" & @CRLF & _
"<PackageReference Include="CommandLineParser" Version="2.2.2" />" & @CRLF & _
"" & @CRLF & _
"<PackageReference Include="Bob" Version="2.2.2" />" & @CRLF & _
"<PackageReference Include="Bob" Version="2.2.1" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")